Debian 11 下运行lantern报错:缺少libappindicator3.so.1

在基于Ubuntu20.04的Elementary OS和基于Debian 10的Deepin 20.2两个系统都能正常安装运行。在Debian 11能正常安装,但运行是却报错:

Running installation script...
/usr/lib/lantern/lantern-binary: 成功
/home/jacky/.lantern/bin/lantern: error while loading shared libraries: libappindicator3.so.1: cannot open shared object file: No such file or directory

通常根据缺少的组件搜索软件包名(libappindicator3),然后安装就可以解决问题。但这次通过apt search libappindicator3 获得的软件包安装后却问题依然存在。上网搜索发现也有其他朋友碰到相同的问题,试了几个办法都不行。在继续尝试中,找了一中能解决问题。原来是缺少了两个依赖,分别为:

# libindicator3-7:
http://ftp.cn.debian.org/debian/pool/main/libi/libindicator/libindicator3-7_0.5.0-2_amd64.deb

#libappindicator3-1:
http://mirrors.ustc.edu.cn/debian/pool/main/liba/libappindicator/libappindicator3-1_0.4.92-3.1_amd64.deb

下载安装这两个依赖后就可以正常运行了。

0 0 vote
Article Rating
Subscribe
提醒
guest
0 评论
Inline Feedbacks
View all comments